What are the minimum requirements to install Tag Groups?

In order to use Tag Groups (free version) you will need:

dom
gmagick
SimpleXML
ssh2
xml
xmlreader
curl
date
exif
filter
ftp
gd
hash
iconv
imagick
json
libxml
mbstring
mysqli
openssl
pcre
posix
sockets
SPL
tokenizer
zlib

Your hosting provider will be able to tell you, if these conditions are met.

WordPress recommends also the following extensions:

gmagick
ssh2
exif
imagick
  • WordPress version 4.0 or higher. Recommended is the latest version.
  • Administrator (or network administrator on a multisite installation) account to install plugins and change settings.
  • Access to the files (for example via FTP) if you need to debug an issue.
  • You will need knowledge of HTML and CSS if you want to customize the styling. Your web designer will be able to help you.
  • WordPress 5.0 or higher or the Gutenberg plugin if you want to use Gutenberg blocks.

The plugin works only with posts, products and similar post types that have tags and with non-hierarchical taxonomies, such as post tags, product tags or other tags. Pages or categories are not supported.

Some features might not work on sites where the core functionalities of WordPress have been modified by other plugins. Unfortunately, it is not possible to develop a plugin for all existing combinations with other plugins and themes. If in doubt, you can always test the plugin.