What is the relevance of free future updates?

Every year sees a series of new WordPress core releases. For each release, plugin and theme developers are urged to test their software against the latest version in order to ensure compatibility.

Now let’s assume that your WordPress site has a lifetime of five or more years. During that time, you certainly don’t want to use any plugin that is years behind its latest version. Because only the latest version can offer you compatibility with the core and the full set of new features.

At many stores, this means that you have to buy the plugin again, year for year. At Codester, however, you pay only once and save money starting from the second year.